The discussion forums in the XSEDE User Portal are for users to share experiences, questions, and comments with other users and XSEDE staff. Visitors are welcome to browse and search, but you must login to contribute to the forums. While XSEDE staff monitor the lists, XSEDE does not guarantee that questions will be answered. Please note that the forums are not a replacement for formal support or bug reporting procedures through the XSEDE Help Desk. You must be logged in to post to the user forums.

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
ibrun fails
sbatch ibrun init phase
Answer
3/9/13 11:44 PM
If I submit any job that uses ibrun to run in parallel I get the following message:

1[c557-201.stampede.tacc.utexas.edu:mpirun_rsh][child_handler] Error in init phase, aborting! (0/1 mpispawn connections)


This is running scripts which a few weeks ago ran fine. What has changed and what do I have to do to get them to run?

RE: ibrun fails
Answer
4/6/13 4:39 AM as a reply to Brendan Fahy.
This problem was solved. The problem was I had edited my .ssh folder. Stamepde user guide says you can not add ssh keys, since they are used for MPI submissions.

I just figured I would update this post with the solution since no one else responded. I had figured out the solution and now getting messages from others with the same problem.

RE: ibrun fails
Answer
6/25/13 5:25 PM as a reply to Mikhail Kibalchenko.
Hi Mikhail,

If you added your keys to ~/.ssh/authorized_keys without removing the existing keys, it should be fine.

You can also put your personal keys in ~/.ssh/authorized_keys2.

Thanks,

John

RE: ibrun fails
Answer
10/15/13 12:19 PM as a reply to John Cazes.
Hi,

I have the same error, and I did accidentally overwrite .ssh/authorized_keys. Is there a way to get back the original keys in there?
Thanks,

/Stefan

RE: ibrun fails
Answer
10/15/13 1:35 PM as a reply to Stefan Lemvig Glimberg.
I solved this now. Move the .ssh folder, then log out and in again and a new .ssh folder is created =)

/Stefan

RE: ibrun fails
Answer
6/9/14 8:21 PM as a reply to Stefan Lemvig Glimberg.
Stefan Lemvig Glimberg:
I solved this now. Move the .ssh folder, then log out and in again and a new .ssh folder is created =)

/Stefan


Hi Stefan,

Could you please tell me what EXACTLY you did to solve this? I encounted the same problem (on gordon, not stampede though) and I tried to move my /.ssh folder to a new directory /.ssh2. Then I logged out and in again. It asked for my password and it did created a new /.ssh folder with different keys. However when I submitted my job again I got the same error as before.

Many thanks!

Haoyuan

RE: ibrun fails
Answer
6/9/14 9:06 PM as a reply to Haoyuan Chen.
Hi Haoyuan,

I did only what you explained you also did. So if it still is not working I am afraid I cannot help emoticon

/Stefan

RE: ibrun fails
Answer
6/9/14 9:29 PM as a reply to Stefan Lemvig Glimberg.
Stefan Lemvig Glimberg:
Hi Haoyuan,

I did only what you explained you also did. So if it still is not working I am afraid I cannot help emoticon

/Stefan



That's okay. I'll keep trying~